[EXTERNAL] Degraded performance Dutch telephony providers

Incident Report for Steam-connect

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:23 CEST

Monitoring

No disruption has been detected on our side. However, due to various reported incidents on https://allestoringen.nl/
affecting multiple providers, users may experience delays when using our software as well as telephony services.

This is outside our control, but due to this issue, our support department can be harder to reach.
Posted Oct 20, 2025 - 10:53 CEST
This incident affected: TRAFFIC (Inbound telephony, Outbound telephony) and STEAM-CONNECT (Platform availability).