[EXTERNAL] Possible degraded performance

Incident Report for Steam-connect

Resolved

This incident has been resolved. No intervention was required from our side.
Posted Jan 22, 2026 - 16:43 CET

Monitoring

Reports on www.allestoringen.nl are declining. This does not yet confirm full resolution, but may indicate that the situation is stabilizing and gradually improving. We continue to monitor closely.
Posted Jan 22, 2026 - 16:02 CET

Identified

We have received reports of issues with calling, network and saving of records that may be caused by factors outside our control. We recommend checking www.allestoringen.nl for updates on potential outages.
Posted Jan 22, 2026 - 15:13 CET