The incident has been resolved. The disruption was caused by a bug in the switching core at our data center provider. They have successfully implemented a fix and taken steps to mitigate the issues experienced on our end. All systems are now operating normally, and we are continuing to monitor the environment closely.
Once our data center provider supplies an RFO, we will publish a detailed report outlining the exact cause on their end.
Posted Mar 23, 2026 - 11:01 CET
Monitoring
Our data center provider has implemented a fix to resolve the recent incident. As part of the recovery process of this external issue, several system restarts were required to restore full operational status.
All services are now running normally, and we are continuing to monitor the environment closely.
Posted Mar 23, 2026 - 10:25 CET
Update
Our data center supplier has found the issue, they are working on a fix.
Posted Mar 23, 2026 - 10:10 CET
Identified
We have identified that the issue is caused by an incident at our data center supplier. We are in close contact with them to resolve this incident as soon as possible.
Posted Mar 23, 2026 - 10:03 CET
Investigating
We are currently investigating reports about degraded telephony performance, MyInsight being unavailable.
The issues are being investigated at our data center supplier.
Support is reachable via our outage line at +31851109400.
Posted Mar 23, 2026 - 09:57 CET
This incident affected: SERVICES (My Insight portal) and TRAFFIC (Inbound telephony, Outbound telephony).