Degradaded performance mobile network (Odido)

Incident Report for Steam-connect

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 12:05 CET

Investigating

We got notified by our mobile supplier that Odido is experiencing an outage. This could give some degradaded performance on the mobile network. Once a fix is implemented by them we will update the statuspage.
Posted Nov 17, 2025 - 10:07 CET
This incident affected: MOBILE SERVICES (Odido (T-Mobile)) and VOICE (Odido (T-Mobile)).