Degraded performance Telephony after power outage at DC

Incident Report for Steam-connect

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 14:40 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 14:20 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 14:15 CEST

Investigating

We are currently investigating reports of degraded telephony performance, which may include call jitter and unstable connections. These issues may still be aftereffects of the power outage at our datacenter experienced this morning. Our IT team is actively investigating and working to resolve the situation.
Posted Oct 21, 2025 - 14:07 CEST
This incident affected: TRAFFIC (Inbound telephony, Outbound telephony).