Our datacenter and systems are now operational. All our telephony services (UCAAS) have been restored, and normal functionality has resumed. We are monitoring the results and all services. Our support team is also available again through our normal channels.
We apologize for any inconvenience this incident may have caused and sincerely appreciate your patience and understanding.
Posted Oct 21, 2025 - 12:49 CEST
Update
MyInsight. trunking, hardphones, inbound and outbound calling should be operational again. Restoring other services still in progress.
Posted Oct 21, 2025 - 12:24 CEST
Update
Services are gradually being restored, for example WebRTC. However, this does not mean that all systems are fully operational yet. We are still in the process of restoring other services and will provide further updates as progress continues.
Posted Oct 21, 2025 - 12:15 CEST
Update
Our datacenter is gradually restoring power and moving toward full operational status. This allows us to start rebooting our systems so they can become fully operational. While services will come back online, some slowness may still be experienced initially after the restoration.
Once we are fully operational, our status page will be updated accordingly.
Posted Oct 21, 2025 - 12:00 CEST
Update
The initial fix applied by the datacenter did not resolve the issue. A new corrective action is currently being prepared for implementation. Next update will be provided on 12:15, or when new information comes available.
Posted Oct 21, 2025 - 11:42 CEST
Update
The issue is identified and a fix is being implemented by our Datacenter. Next update will be provided on 11:45.
Posted Oct 21, 2025 - 11:23 CEST
Identified
Our datacenter is currently experiencing a power outage. This datacenter supports our telephony services, which are currently impacted. We are in close contact with our datacenter partner and are awaiting a resolution.
Posted Oct 21, 2025 - 11:13 CEST
Investigating
We are currently investigating reports about telephony issues on our services.
Our support team is available via our outage number.
Posted Oct 21, 2025 - 11:08 CEST
This incident affected: SERVICES (My Insight portal), TRAFFIC (Inbound telephony, Outbound telephony), and TELEPHONY STEAM-CONNECT (Datacenter).