WebRTC connections drops

Incident Report for Steam-connect

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 16:50 CET

Monitoring

A fix is implemented. WebRTC connections are slowly restoring. We are monitoring the results and investigation of root cause is still ongoing.
Posted Mar 23, 2026 - 15:50 CET

Identified

The issue is identified and a fix is being implemented.
Posted Mar 23, 2026 - 15:43 CET

Update

We are investigating together with our data center provider to see where this incident is coming from.
Posted Mar 23, 2026 - 15:32 CET

Investigating

We are currently investigating reports about degraded telephony performance and issues with WebRTC connection.
Posted Mar 23, 2026 - 15:24 CET
This incident affected: TRAFFIC (Inbound telephony, Outbound telephony).