Performance Degradation on Steam-connect

Incident Report for Steam-connect

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 16:53 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 15:56 CEST

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 15:36 CEST

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 15:17 CEST

Investigating

A segment of our customers can experience performance degradation on our Steam-connect platform. This is resulting in slower response times across various functions and services within the application. Our engineering team is actively investigating the root cause and working diligently to resolve the issue to restore normal performance levels.
Posted Jul 23, 2026 - 14:59 CEST
This incident affected: STEAM-CONNECT (Datacenter, Loading speed, RTM, RTD, Reporting).