Degradaded performance mobile network (Odido)

Incident Report for Steam-connect

Resolved

Voice traffic is not affected anymore and should be working as expected.
Posted Dec 03, 2025 - 16:42 CET

Monitoring

We received the message that traffic is restoring on Odido's network.
Posted Dec 03, 2025 - 13:25 CET

Identified

We got notified by our mobile supplier that Odido is experiencing an outage. This could give some degradaded performance on the mobile network. Once a fix is implemented by them we will update the statuspage.
Posted Dec 03, 2025 - 11:03 CET
This incident affected: MOBILE SERVICES (Odido (T-Mobile)) and VOICE (Odido (T-Mobile)).