Completed
The scheduled maintenance has been completed.
Posted Nov 26, 2025 - 00:00 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 22:15 CET
Scheduled
To improve your experience of Steam-connect we will perform additional maintenance. We apologize for any inconvenience caused during this maintenance and thank you for your understanding.
Posted Nov 18, 2025 - 09:58 CET
This scheduled maintenance affected: AGENDA SYNC (Exchange sync, Google sync, MS 365 sync), SOCIAL MEDIA (Facebook, Instagram, Twitter, WhatsApp Business, Facebook Messenger), SERVICES STEAM-CONNECT (Address import, API, CDRA, Iban, PC NL, Mail merges, MDB, PD, SMS, TTC, RVB), TRAFFIC (Chat, Email inbound, Inbound telephony, Outbound telephony), STEAM-CONNECT (Datacenter, Loading speed, Platform availability, RTM, RTD, Reporting, Rostering, Record management), TELEPHONY STEAM-CONNECT (Portal, Voice, WebRTC, Queueing, Datacenter), and SERVICES (My Insight portal).